Ansible with ARA on RHEL7/CentOS7, welcome to hell!
2020-02-04, 16:00–16:50, B.1.017

A lot of servers still run RHEL7 or CentOS7. But running Ansible with ARA on this moves you into dependency hell.
ARA needs Python3, CentOS delivers this, but not in /usr/bin/python. ARA needs nodejs. CentOS only has an old version..........

I will try to show you how I solved this hell and created a working Ansible with ARA environment


Installing ARA (https://ara.recordsansible.org/) used to be a breeze, but with the newest version the newest version of NodeJS is required as is Python3. Both are standard not available on RHEL7 and CentOS7, so, so tricks need to be used to get things going,

In this presentation I'll try to show the way to solve this problem